<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:"
        panose-1:0 0 0 0 0 0 0 0 0 0;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
p.paragraph, li.paragraph, div.paragraph
        {mso-style-name:paragraph;
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
span.normaltextrun
        {mso-style-name:normaltextrun;}
span.spellingerror
        {mso-style-name:spellingerror;}
span.eop
        {mso-style-name:eop;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">Support,<o:p></o:p></p>
<p class="MsoNormal">I am unit testing an hdl worker with eight test cases to cover eight operational modes of the component. I have input and output fles for each. This worker does not emit a ZLM on the output upon completion of the input file so the test
 cases look like:<o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:8.0pt;font-family:"Courier New"">        <case duration='300'><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:8.0pt;font-family:"Courier New"">               <input port='in' file="../../../test_vectors/PassbandIQ_NonHT_MCS0_Fs20MHz.rx1.raw" /><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:8.0pt;font-family:"Courier New"">               <output port='out' file='../../../test_vectors/PassbandIQ_NonHT_MCS0_Fs20MHz_RxOutVec.bin'/><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:8.0pt;font-family:"Courier New"">        </case><o:p></o:p></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Since this test takes a long time I would like to let it run regardless of failure of any of the cases so I run this as:<o:p></o:p></p>
<p class="paragraph" style="margin:0in;margin-bottom:.0001pt;vertical-align:baseline">
<span class="normaltextrun"><span style="font-size:10.0pt;font-family:"Courier New";color:black">make run
</span></span><span class="spellingerror"><span style="font-size:10.0pt;font-family:"Courier New";color:black">TestAccumulateErrors</span></span><span class="normaltextrun"><span style="font-size:10.0pt;font-family:"Courier New";color:black">=0</span></span><span class="eop"><span style="font-size:10.0pt;font-family:"Courier New";color:black"> </span></span><span style="font-size:9.0pt;font-family:"&quot",serif;color:black"><o:p></o:p></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">TestAccumulateErrors=0 has no effect – seems like it applies to different targets rather than cases<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Question: How can I write test cases/ make run commands to get it to run the cases regardless of failure?<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Sincerely,<o:p></o:p></p>
<p class="MsoNormal">Peter B. Miller<o:p></o:p></p>
<p class="MsoNormal">Potomac: (301) 765-9668<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
--------------------------- This email and any files transmitted with it are confidential and intended solely for the use of Signalscape, Inc. and the addressed individual or entity. If you have received this email in error please delete it. Information in
 this email may be subject to the Privacy Act of 1974 and any unauthorized review, use, disclosure, or distribution is strictly prohibited. Any views or opinions presented in this email are solely those of the author and do not necessarily represent those of
 the company.
</body>
</html>